Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Exception while parsing of large EDI 834 files

SA-33604

Summary



The user is using Pega 717 with Healthcare Industry Foundation v7.12. They have reported poor performance and exceptions while loading of the EDI file. Once the file listener picks-up the EDI file of approximately size 6 MB, the processing takes 2-3 hours to complete along with several exceptions seen in PegaRULES log file. Investigation of debug logs suggests that exception is being thrown at the time of parsing X12Message in Step 1 of the OOTB activity named PegaX12-Data-N834.X12ParseMessage.


Error Messages



2017-01-25 21:02:27,068 [http-bio-9080-exec-9] [ STANDARD] [PegaImpl:01.08.01] (ponse.PegaX12_Data_N834.Action) INFO []|[]|Enroll_ElogTask_File/pyStartCase/Intake834ServiceFile PegaUser - INBOUND Parsing: FAILED TO PARSE Segment ID: NM1 in Loop: 2100A
2017-01-25 21:02:27,089 [http-bio-9080-exec-9] [ STANDARD] [PegaImpl:01.08.01] ( internal.util.PRParseUtils) ERROR []|[]|Enroll_ElogTask_File/pyStartCase/Intake834ServiceFile PegaUser - Delimited parsing failed
com.pega.pegarules.pub.PRException: Exception attempting to load PegaX12-Data-DMG_DemographicInformation/ParseX12/NM1.
From: (H837BD6DDB7F6005568E11B23C7AA129A:[])
at com.pega.pegarules.integration.engine.internal.mapping.PropertiesParseDelimited.getInstance(PropertiesParseDelimited.java:182)
at com.pega.pegarules.integration.engine.internal.mapping.DelimitedParserBase.parse(DelimitedParserBase.java:860)
at com.pega.pegarules.integration.engine.internal.util.PRParseUtils.parseDelimited(PRParseUtils.java:290)
at com.pegarules.generated.activity.ra_action_prepare834response_9b1cccfc41048cd4f3762ecb95a728b0.step1_circum0(ra_action_prepare834response_9b1cccfc41048cd4f3762ecb95a728b0.java:518)
at com.pegarules.generated.activity.ra_action_prepare834response_9b1cccfc41048cd4f3762ecb95a728b0.perform(ra_action_prepare834response_9b1cccfc41048cd4f3762ecb95a728b0.java:72)
at com.pega.pegarules.session.internal.mgmt.Executable.doActivity(Executable.java:3375)
at com.pega.pegarules.session.internal.mgmt.Executable.invokeActivity(Executable.java:10454)
at com.pegarules.generated.activity.ra_action_generate834outbound_0679d37be231bf635f75194053529719.step2_circum0(ra_action_generate834outbound_0679d37be231bf635f75194053529719.java:254)
at com.pegarules.generated.activity.ra_action_generate834outbound_0679d37be231bf635f75194053529719.perform(ra_action_generate834outbound_0679d37be231bf635f75194053529719.java:92)
at com.pega.pegarules.session.internal.mgmt.Executable.doActivity(Executable.java:3375)
at com.pega.pegarules.session.internal.mgmt.Executable.invokeActivity(Executable.java:10454)
at com.pegarules.generated.activity.ra_action_x12processstart_55a116d2be98411067dad00d1c833c47.step1_circum0(ra_action_x12processstart_55a116d2be98411067dad00d1c833c47.java:167)
at com.pegarules.generated.activity.ra_action_x12processstart_55a116d2be98411067dad00d1c833c47.perform(ra_action_x12processstart_55a116d2be98411067dad00d1c833c47.java:69)
at com.pega.pegarules.session.internal.mgmt.Executable.doActivity(Executable.java:3375)
at com.pega.pegarules.session.internal.mgmt.Executable.invokeActivity(Executable.java:10454)
at com.pegarules.generated.activity.ra_action_x12parsemessage_301393e42e735719e720215228144844.step5_circum0(ra_action_x12parsemessage_301393e42e735719e720215228144844.java:825)
at com.pegarules.generated.activity.ra_action_x12parsemessage_301393e42e735719e720215228144844.perform(ra_action_x12parsemessage_301393e42e735719e720215228144844.java:150)


Steps to Reproduce

  1. Import large EDI 834 files using Pega provided OOTB activities in Healthcare Industry Foundation v7.12.
  2. The import process is very slow and takes 2-3 hours to complete and exception is thrown at the time of parsing X12Message in Step 1 of the OOTB activity named PegaX12-Data-N834.X12ParseMessage.


Root Cause



This issue was determined to be a product enhancement request in Healthcare Industry Foundation framework.

Resolution



An enhancement request, FDBK-18240, has been created for consideration by Pega Product Management.

Published March 3, 2017 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us