Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

ExcludeAgents JVM setting fails for agent names containing space



When trying to exclude particular agents to run in a specific node using below JVM argument:


The setting does not work when used with Agent name that includes spaces, for example:

-DExcludeAgents=Pega-Engine:Collect PegaDATA database blob size statistics

Error Messages

Not Applicable

Steps to Reproduce

1. Attempt to exclude the agent using the -DExcludeAgent JVM argument.
2. Start Pega application.
3. Observe agent with spaces in its name is still running.

Root Cause

Arguments were not being passed into the Java options correctly.


To resolve this issue, properly encapsulate the java options in quotes. Note that the below example is windows:

set JAVA_OPTS=-Xms4096m -Xmx4096m -XX:MaxMetaspaceSize=1024m -DExcludeAgents="Pega-Engine:Collect PegaDATA database blob size statistics"

Also, if one must include multiple agents in the same argument use commas to separate the agent names as is documented here:

Published February 20, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us