Support Article
Export to PDF is not working and is displaying blank screen
SA-37286
Summary
When you export a a report definition to PDF with more than 10,000 records, the export fails and displays a blank screen with Pega 7.1.8.
Error Messages
2017-03-16 12:22:24,226 [ WebContainer : 3] [ ] [ ] (ngineinterface.service.HttpAPI) ERROR <server>|<IP> - <IP>: com.pega.pegarules.pub.context.RequestorLockException
com.pega.pegarules.pub.context.RequestorLockException: Unable to synchronize on requestor H667F660012C8D90B935AC14A8FCDEC65 within 1080 seconds: (thisThread = WebContainer : 3) (originally locked by = WebContainer : 5) (finally locked by = WebContainer : 5)
Steps to Reproduce
1. Create Report definition to get the summary of the report and on click of the record launch the detailed report.
2. Make sure that report have the more than 10,000 records.
3. Click Export to PDF option. Blank screen displays.
Root Cause
A defect or configuration issue in the operating environment.
A custom report definition used with Export to PDF has 10,000+ rows contained in it.
Resolution
Here’s the explanation for the reported behavior:
The current implementation of Export to PDF is known to take 10+ minutes to export over 10,000 rows.
Ignoring the format options will help if they have controls configured on their columns, but not by much.
Consider breaking up the report into smaller pieces.
If user still continues to run the report as is, users must be patient and allow the report to finish.
If user starts to perform other work in PRPC while the report is running, then they will likely get the requestor lock exceptions and they will not be provided with the report.
Published June 2, 2017 - Updated October 8, 2020
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