Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Export to PDF - Unresponsive session & RequestorLockException

SA-3657

Summary



The Export to PDF feature in a ListView or Report Definition can cause the user's session to become unresponsive if the report contains too much data in the results.  A RequestorLockException (Unable to synchronize on requestor) may also be seen in the log file related to this issue.

Error Messages



13 Nov 2014 15:54:42,775 [http-bio-8082-exec-8] (ngineinterface.service.HttpAPI) ERROR serverB|IP_Address1 - IP_Address2: com.pega.pegarules.pub.context.RequestorLockException
com.pega.pegarules.pub.context.RequestorLockException: Unable to synchronize on requestor HDEE2CBADD97A781E548083BFE777895A within 120 seconds: (thisThread = http-bio-8082-exec-8) (originally locked by = http-bio-8082-exec-2) (finally locked by = http-bio-8082-exec-2)
at com.pega.pegarules.session.internal.PRSessionProviderImpl.getLockOnRequestor(PRSessionProviderImpl.java:1359)
at com.pega.pegarules.session.internal.PRSessionProviderImpl.doWithRequestorLocked(PRSessionProviderImpl.java:912)
at com.pega.pegarules.session.internal.PRSessionProviderImpl.doWithRequestorLocked(PRSessionProviderImpl.java:811)

...

Steps to Reproduce



1. Create a report that returns a lot of data
2. Run the report
3. Export the results to a PDF file



Root Cause



The root cause of this problem is a defect/misconfiguration in the application. Any Report Type that provides an option to Export to PDF could result in an unresponsive session  requestor timeout error in the logfile if the report is takes longer than the 2 minute browser timeout to return its data.


Resolution



This issue is resolved through the following local change: Revise the query parameters to return less content in the report, or remove the Export to PDF option.
Suggest Edit

Published January 31, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us