Support Article
External assignment locking issue
SA-39023
Summary
When the user opens an external assignment and closes it without submitting it, it can not be reopened.
Error Messages
Access Denied
This request for information cannot be processed (another request is currently being processed).
Steps to Reproduce
- Create an external assignment and email its link to a user.
- Next open an assignment and close it.
- Attempt to re-open it.
Root Cause
When a work tab within the browser is closed, the server is not notified when the tab is closed. Hence, a subsequent open of same work will succeed but attempting to open a different one will fail.
Resolution
If the browser tab is closed but the browser session is still open, the work is still locked. Attempting to open that work in a second browser session will fail because the lock is still held. Note: A useful screen on the developer portal for checking the locks to see when one has been released or retained is the following: DesignerStudio > Process & Rules > Tools > Work Admin > All Locks.
Published June 17, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.