Support Article

External assignment not able to open from email-Pega Express

SA-33562

Summary



User requires to reuse the invite collaborator functionality provided in Pega express in Field Service Management application.

When user test the Pega express "invite people to your application" the email has been sent to the user.

But when the user clicks on the create my account link from the mail a new window opens up but no information is visible showing 400 error.


Error Messages



400 error for Internet Explorer, and it is directly visible for Chrome Click F12 and go to the console.


Steps to Reproduce

  1. Switch to Pega express.
  2. Click on Users in the left Navigation pane. A modal will be opened.
  3. In the People tab go to bottom of the page to see "Invite people to your application".
  4. Enter your email address and select any role and click Send Invitation.You will receive an email.
  5. Click on the "Create My Account" in the email.
  6. Observe a new window will be opened up with blank page which will show 400 error (if you click F12 and go to the console).

Expected: Instead of the blank window a form with UserID, User name and Password should be opened.


Root Cause



Double encoding issue.

External Assignment processing has issues, probably an issue with unsafe URL characters present in pzSignature query parameter.

Resolution



Apply HFix-32032.




Published February 10, 2017 - Updated February 20, 2017


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