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Support Article

Failed to find a 'RULE-OBJ-MODEL' with the name '""'

SA-84606

Summary



After receiving the 'No Work Available' message in the User portal, work is assigned to the operator. A message must display on the user's screen to indicate that work is available. Instead, the 'There has been an issue; please consult your system administrator' message displays.


Error Messages



Failed to find a 'RULE-OBJ-MODEL' with the name '""' that applies to 'Data-Portal'; no rules with this name were found in the rulebase.


Steps to Reproduce

  1. Launch the User portal.
  2. Click the Next Assignment.
  3. Ensure that no assignment is available to the user. The 'No Work Available' message displays.
  4. Assign an assignment to this user using a different operator.


Root Cause



A defect or configuration issue in the operating environment.
When the preDataTransformName (10th parameter) is passed as the browser 'event' object to the pega.desktop.showHarnessWrapper API, the 'model' parameter is passed as double quotes instead of an empty string. Hence, the server activity flow was incorrect.



Resolution



Perform the following local-change:

Change pega.desktop.showHarnessWrapper('newDocument', 'Data-Portal', 'NewWorkAvailable', "", "", "", "", "", "", event); to pega.desktop.showHarnessWrapper('newDocument', 'Data-Portal', 'NewWorkAvailable', "", "", "", "", "", "", "");

Published October 12, 2019 - Updated December 2, 2021

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