Support Article
Failed null:error with duplicate email check
SA-38949
Summary
Duplicate Email Check throwing irrelevant error in case of Account with Sales Automation 7.21.
Whereas in case of Contact, it throws error :"A contact already has this Mail".
It is expected to have same error message, that is, "A contact already has this Mail" in both the cases, that is, while creating new contact in case Account and Contact.
Error Messages
Failed null
Steps to Reproduce
1. Log in as SFASysAdmin.
2. In Contact Create Screen, create a new contact.
3. For Work Email field if email address is entered which is already existed for other contact then it throws an error message:
"A contact already has this Mail".
4. But, while creating a new contact from Account, error message for duplicate Work Email is :"Failed null"
Root Cause
A defect in Pegasystems’ activity rule PopulateContactLinkDetails.
The data page referenced in 15th step of the activity rule was D_LinkContactPage instead of LinkContactPage which was the step page in the previous steps of the activity. Since D_LinkContactPage data page is not built in the activity and it was accessed, it was throwing error.
Resolution
Perform the following local-change steps:
- In the activity rule, PopulateContactLinkDetails of class PegaCRM-Link-Entity- and Ruleset : PegaCRM-SFA:07-21-01.,
- In the 15th step, add Message as "FailedMsgsOnPage\t" + @getMessagesAll(LinkContactPage).
Published July 26, 2017 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.