Support Article
Failed to save Campaign Strategy
SA-34106
Summary
User has created an Campaign and when trying to run the Campaign, it is failing with the below error.
Error Messages
Your campaign has failed with the following message:
Failed to create the strategy for this campaign
To resolve the issue, review the strategy {Strategy Name}
Steps to Reproduce
- Create a Sample Campaign.
- Try to run the Campaign.
Root Cause
An issue in the custom application code or rules .
Customer Data Class and Top level SR class were in different rulesets. Ruleset Validation mode was set for ruleset XXX which has the customer class.
When the campaign is submitted to execution the strategy which is supposed to be created in the customer class failed as the SR properties are not visible to customer data class.
Resolution
Perform the following local-change:
Set Application Validation mode for ruleset containing the customer data class and Top level SR class.
Published March 10, 2017 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.