Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Failed to save Campaign Strategy

SA-34106

Summary



User has created an Campaign and when trying to run the Campaign, it is failing with the below error.


Error Messages



Your campaign has failed with the following message:
Failed to create the strategy for this campaign
To resolve the issue, review the strategy {Strategy Name}


Steps to Reproduce

  1. Create a Sample Campaign.
  2. Try to run the Campaign.


Root Cause



An issue in the custom application code or rules .

Customer Data Class and Top level SR class were in different rulesets. Ruleset Validation mode was set for ruleset XXX which has the customer class.

When the campaign is submitted to execution the strategy which is supposed to be created in the customer class failed as the SR properties are not visible to customer data class.

Resolution



Perform the following local-change:

Set Application Validation mode for ruleset containing the customer data class and Top level SR class.

Published March 10, 2017 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us