Support Article
Failed to send test message due to configuration error
Summary
User is getting "Failed to send test message due to configuration error" messaging when trying to configure a new SMSC.
Error Messages
Failed to send test message due to configuration error.
Steps to Reproduce
Rebuild the resetting, restart the backend service.
Root Cause
User was facing the following issues:
Issue: Failed to send test message due to configuration error.
Root Cause: Incorrect value specified for Vantage parameter "VenvDbaseURL".
Issue: File MMMessage.dtd not found error while performing test connectivity in eSettings.
Root Cause: Files to start CMD services were in a separate directory from the CMD bin directory.
Issue: When performing SMS test delivery in Treatments, connection does not automatically unbind after treatment is completed.
Root Cause: Vantage parameter "VenvSMSOutboundMode" was set to "ASYNC".
Issue: Chinese characters are not getting displayed properly in SMS even after setting Vantage parameters "VenvSMSTextEncoding" to "GSM" and "VenvSMSDataCodingScheme" to 8.
Root Cause: Value of locale on user's CMD server machine was found to be "en_US.UTF-8". Issue: Connection was getting timed out when trying to perform test connectivity of newly configured SMSC in production.
Root Cause: Load balancer was not configured correctly.
Resolution
Suggested the following local changes to user:
Issue: Failed to send test message due to configuration error.
Answer: Retype Vantage parameter "VenvDbaseURL".
Issue: File MMMessage.dtd not found error while performing test connectivity in eSettings.
Answer: Copy MMMessage.dtd file from CMD bin directory to directory containing files to start CMD services.
Issue: When performing SMS test delivery in Treatments, connection does not automatically unbind after treatment is completed.
Answer: Set Vantage parameter "VenvSMSOutboundMode" to "SYNC".
Issue: Chinese characters are not getting displayed properly in SMS even after setting Vantage parameters "VenvSMSTextEncoding" to "GSM" and "VenvSMSDataCodingScheme" to 8.
Answer: Update value of locale on CMD server machine to "en_US.utf8" (utf8 is in lowercase and without a hyphen).
Answer: Reconfigure load balancer to accommodate new SMSC.
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Published May 24, 2017 - Updated December 2, 2021
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