Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Failure while opening the rule instance with IE 8

SA-10961

Summary



Using Internet Explorer 8, user cannot open rule instances from the Application Explorer.  User cannot open rule instances via other means as well.

Error Messages



Failure opening the Rule Instance.

When traced @baseclass.WBOpen fails at step 3 with the fail message
Database.NotFound


Steps to Reproduce



Try to open the operator record, access group record, or any rule from the Application Explorer.

Root Cause



The root cause of this problem is a defect/misconfiguration in the operating environment combined with an error in Pegasystems code.
When running Internet Explorer 8, the operation tries to open the rule in a new window, and there is a fixed bug in Pega 7.1.8 which involves a missing parameter to perform  WBOpen when trying to show the rule in a new window.


Resolution



This issue is resolved by making the following change to the operating environment:
Upgrade to a new version of Internet Explorer, and the rule will open in a tab instead of a new window.  
This exercises different code, avoids the bug, and has a successful conclusion.
Suggest Edit

Published June 30, 2015 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us