Support Article
Field 79 validation issue when Sent to CC party is selected
SA-11055
Summary
Field 79 validation fails when Sent to CC party is selected.
Field 79 in swift messages must have a maximum of 35 lines. Even though SI (Pega Smart Investigate) provides validation for this field 79 to be 35 lines , it fails to provide validation for field 79 when sending correspondence to another party by selecting "Send to CC".
Correspondence is sent to original party but not to the party in CC.
Error Messages
Not Applicable
Steps to Reproduce
1. Create a case and send a swift correspondence with tickler enabled and also send the correspondence to another party by selecting "Send to CC".
2. Fill the maximum number of lines for field 79 (35).
3. Submit the correspondence, this swift message is sent successfully as it has valid number (35 lines).
4. But while sending correspondence to party in CC, Field 79 validation fails and correspondence is not sent to CC party.
Root Cause
The root cause of this problem is a defect in Pegasystems’ code/rules.
Field 79 in swift messages should have a max of 35 lines as per standard. Even though SI provides validation for this field 79 to be 35 lines, it fails to validate for field 79 when sending correspondence to another party by selecting "Send to CC" and User at this stage has option to correct or edit the F79 field.
Resolution
Installing HFix-22469 resolves this issue by providing user an option to edit the CC message which otherwise is a read-only field.
Published June 25, 2015 - Updated October 8, 2020
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