Support Article
Filter popup does not display values when using custom control
SA-60094
Summary
In a report definition rule, custom control is used as the control for one of the columns. While filtering the column after running the report definition rule, the filter values do not display correctly.
Error Messages
Not Applicable
Steps to Reproduce
- Create a report definition rule.
- Add two properties Prop A and Prop B.
- Create a custom control rule.
- Assign a value to Prop B using the custom control.
- Define a logic in the custom control, such that Prop A value is used to determine the value for Prop B
- Use this custom control as the control for Prop B in the report definition.
- Save and Run the report definition.
- Filter the Prop B column.
Root Cause
Filtering on a column is not supported when the corresponding control has logic which depends on the remaining property values of the report definition.
Resolution
Perform either of the following local-changes:
- Change the custom control logic
- Use Rule Alias functions instead of custom control.
Published August 24, 2018 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.