Support Article
First column in the tree grid not visible in Internet Explorer
SA-4913
Summary
The application is developed on CPM 7.1 R2 and PRPC 7.1.6. User has configured a 'Tree Grid' to be shown under work basket tab of OOTB CPM Account Manager Portal. The source of this repeat grid is a page list property. When the CPM Account Manager portal is launched and user navigates to workbasket tab, it is observed that the first column of Tree Grid is not visible. This occurs only in IE browser. When the same use case is performed on Chrome / Firefox browser, user can’t see the first column of tree grid.
Error Messages
No error message.
Steps to Reproduce
1) Do a 'Save As' of OOTB section 'CPMMyWorkbasketList'. This section is referenced under workbasket tab of CPM Account Manager / CPM Manager Portal.
2) This section uses a repeat grid to show the data. Replace the repeat grid with a tree grid and use a PageList property as the source of this tree grid.
3) Launch the CPM Account Manager portal and navigate to 'workbasket' tab. It could be seen that the first column of tree grid is not visible to user.
The issue is observed only in IE browser. Moreover, if we change the source of the repeat grid to a 'Report Definition', the issue does not occur in IE .
Root Cause
A new feature has been introduced in Pega 7.1.6 version to customize the 'No Items' section related to repeat grid. When there are no records in grid, a 'No items' section is shown in data part of grid. As part of new feature, user can customize this 'No Items' section as per the need. This new feature lead to the problem reported. The issue is addressed in Pega 7.1.7.
Resolution
The fix is available in Pega 7.1.7.
Published January 31, 2016 - Updated October 8, 2020
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