Support Article
Flow fails on setting MinimumAgeForProcessing property in ms
SA-55944
Summary
The flow fails on setting the MinimumAgeForProcessing property in milliseconds (ms) in the Queue-For-Agent method.
Error Messages
Not Applicable.
Steps to Reproduce
- Log in to the application
- Get the DateTime difference for a date >25 days in MinimumAgeForProcessing property in milliseconds which comes up to 2160000000
- Set it in the Queue-For-Agent method on a post activity of local action and save it to an activity
Root Cause
A defect or configuration issue in the operating environment. The MinimumAgeforProcessing property is mapped to an integer and does not support a value more than 2147483647 in milliseconds.
Resolution
Perform the following local-change:Use the enqueue() method instead of using the Queue-For-Agent method to use pyMinimumDateTimeForProcessing for scheduling an agent as per a given date in future.
- Perform a Page-New > StepPage1
- Use Property-Set:
StepPage1.pyAgentName to [Agentruleset:AgentName] e.g. "Pega-ProCom:ServiceLevelEvents"
StepPage1.pyItemStatus to "Scheduled"
StepPage1.pyMaxAttempts to Value
StepPage1.pyMinimumDateTimeForProcessing to @DateTime.addToDate("20180418T013020.420 GMT","5","10","10","10") [Use datetime library here to compute curent date + 25 days]
- Add the below JavaScript:
try {
tools.getThread().getQueueManager().enqueue(myStepPage);
}
catch (DatabaseException de)
{
tools.getPrimaryPage().addMessage(de.getMessage());
}
- Commit the rule
Published August 24, 2018 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.