Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Flow in a modal dialog action does not work

SA-96645

Summary



Post upgrade to Pega Platform 8.3, the Flow in a modal dialog action does not work. However, the same functionality works with the Launch local action.


Error Messages



pzpega_ui_harness_deferred_before_14195107074!!.js:447 Uncaught TypeError: Cannot set property 'value' of null
    at pega.ui.Doc.submitWrapper (pzpega_ui_harness_deferred_before_14195107074!!.js:447)
    at pega.ui.Doc.submit (pzpega_ui_harness_deferred_before_14195107074!!.js:447)
    at doFormSubmit

Steps to Reproduce

  1. Launch the Robot Manager (RM) portal.
  2. On click of a button in the RM portal, launch a flow in a modal dialog.
  3. Click the Submit button.


Root Cause



The flowinModalDialog created another thread, due to which the current thread is not submitted. However, when the Launch local action is used, the local action is in the same context and the modal dialog is submitted accordingly.


Resolution



Here’s the explanation for the reported behavior:

As a local-change, use the Launch local action instead of flowinModalDialog.
Suggest Edit

Published January 10, 2020 - Updated December 2, 2021

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us