Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Flow in modal dialog action not work post Pega 8.3 upgrade

SA-96076

Summary



On click of a button in the UI, flow in a modal dialog does not work.


Error Messages



pzpega_ui_harness_deferred_before_14195107074!!.js:447 Uncaught TypeError: Cannot set property 'value' of null
    at pega.ui.Doc.submitWrapper (pzpega_ui_harness_deferred_before_14195107074!!.js:447)
    at pega.ui.Doc.submit (pzpega_ui_harness_deferred_before_14195107074!!.js:447)
    at doFormSubmit



Steps to Reproduce

  1. Launch the Robot Manager (RM) portal.
  2. On click of a button in the RM portal, launch a flow in a modal dialog.
  3. Click Submit.


Root Cause



The flow in modalDialog action rendered the pzModalFlowTemplate which pointed to Pega Platform 7.4.


Resolution



Perform the following local-change:

On the button, launch a local action such that it renders the pzModalTemplate (this is the latest template in Pega Platform 8.3.1).
Suggest Edit

Published December 19, 2019 - Updated December 2, 2021

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us