Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Formatted email in the Alerts log

SA-47027

Summary



Service Email Listener triggers exceptions in Alerts log. This occurs when the email content displays in the log in various formats.


Error Messages



437 GMT*6*PEGA0020*1955*1000*ee2f5adeea7cffb650f5a925d63c4932*A1F29AE9BA570AF218210A2CA20F5F324<your_workgroup>:01.01.04*a34d770a709cedf802a5c883fe05523f*N*5*8079*java.lang.ThreadGroup[name=<your_name>: E2EIDSimplePegaRulesProd07_LV2,maxpri=10]*STANDARD*com.pega.pegarules.session.internal.mgmt.Executable*EMAIL.<your_emaillistener>|from(<emailid>)|sub(FW: <your_Subject>)|Email|EmailDefault|<your_classname>|<your_emailaccountname>|A1F29AE9BA570AF218210A2CA20F5F324*ServicePAL.Email.EmailDefault.<your_classname>-NotifyDocument.<>*Rule-Obj-Activity:ProcessEmail*RULE-CONNECT-SOAP <your_soaprule> #20111219T095058.658 GMT Step: 12 Circum: 0*454:With embedded;455:With embedded;456:getStream Rule-Obj-XML:<your_XML>.MapFrom;457:With embedded;458:getStream Rule-Obj-XML:<your_activityrule><your_activityrule>.MapFrom;459:With embedded;460:With embedded;461:With embedded;462:appendStream Rule-Obj-XML:document;463:With embedded;464:With embedded;465:With embedded;466:With embedded;467:With embedded;468:With embedded;469:With embedded;470:With embedded;471:With embedded;472:With embedded;473:appendStream Rule-Obj-XML:hasTypes;474:Transitions;475:RULE-OBJ-ACTIVITY RULE-CONNECT-SOAP INVOKE #20110712T003236.063 GMT Step: 8 Circum: 0;476:Java;477:doActivity Rule-Obj-Activity:<your_soaprule>;478:RULE-OBJ-ACTIVITY RULE-CONNECT-SOAP <your_soaprule> #20111219T095058.658 GMT Step: 1 Circum: 0;479:Java;480:RULE-OBJ-ACTIVITY RULE-CONNECT-SOAP <your_soaprule> #20111219T095058.658 GMT Step: 2 Circum: 0;481:Java;482:RULE-OBJ-ACTIVITY RULE-CONNECT-SOAP <your_soaprule> #20111219T095058.658 GMT Step: 3 Circum: 0;483:Java;484:RULE-OBJ-ACTIVITY RULE-CONNECT-SOAP <your_soaprule> #20111219T095058.658 GMT Step: 4 Circum: 0;485:Java;486:RULE-OBJ-ACTIVITY RULE-CONNECT-SOAP <your_soaprule> #20111219T095058.658 GMT Step: 5 Circum: 0;487:Preconditions;488:RULE-OBJ-ACTIVITY RULE-CONNECT-SOAP <your_soaprule> #20111219T095058.658 GMT Step: 6 Circum: 0;489:Preconditions;490:RULE-OBJ-ACTIVITY RULE-CONNECT-SOAP <your_soaprule> #20111219T095058.658 GMT Step: 7 Circum: 0;491:Java;492:RULE-OBJ-ACTIVITY RULE-CONNECT-SOAP <your_soaprule> #20111219T095058.658 GMT Step: 8 Circum: 0;493:Java;494:RULE-OBJ-ACTIVITY RULE-CONNECT-SOAP <your_soaprule> #20111219T095058.658 GMT Step: 9 Circum: 0;495:Java;496:RULE-OBJ-ACTIVITY RULE-CONNECT-SOAP <your_soaprule> #20111219T095058.658 GMT Step: 10 Circum: 0;497:Java;498:Transitions;499:RULE-OBJ-ACTIVITY RULE-CONNECT-SOAP <your_soaprule> #20111219T095058.658 GMT Step: 11 Circum: 0;500:Java;501:RULE-OBJ-ACTIVITY RULE-CONNECT-SOAP <your_soaprule> #20111219T095058.658 GMT Step: 12 Circum: 0;502:Java;503:doAction Rule-Parse-XML;*pxServiceActivityElapsed=0.22;pxOtherIOCount=2;pxTrackedPropertyChangesCount=1;pxTotalReqCPU=0.34;pxJavaStepElapsed=0.02;pxDBInputBytes=10,381;pxOtherCount=2;pxRuleCount=1;pxRunStreamCount=4;pxRulesUsed=132;pxOtherIOElapsed=0.01;pxTotalReqTime=2.17;pxActivityCount=3;pxJavaStepCount=15;pxConnectElapsed=1.96;pxAlertCount=1;pxRuleFromCacheCount=1;pxRulesExecuted=9;pxOtherFromCacheCount=1;*Rule-Connect-SOAP**Rule-Connect-SOAP**doActivity Rule-Obj-Activity:Invoke;Connect-SOAP;RULE-OBJ-ACTIVITY <your_class>- <your_activityrule> #20131008T102219.752 GMT Step: 7 Circum: 0;doActivity Rule-Obj-Activity:<your_activityrule>;Call <your_activityrule>;12 additional frames in stack;*SubString1=<your_emailid>;PartyId=;FirstIndexInCCId=-1;DOCUMENT_CLASS_ID=<your_documentClassID>;Length=1;Parameter=;contactPointId=00000error;TempTo=GRP LARGE CORPORATE MIDLANDS <<your_emailid>>SEMICOLON;test=SubjectEQUALSCBO-1665490 // CBO-1660949 Drawing Cash from our accounts,SenderEQUALS<your_emailid>,RecipientTOEQUALS<your_emailid>,RecipientCCEQUALS,TimeStampEQUALS20170919T155004.000 GMT;DocumentType=;LastIndexInToId=-1;CaseHandle=;MustReturnSecurity=TRUE;InitialOriginatorType=013;EndPointURL=<your_EndPointURL>;SecurityId=your_SecurityToken;UNPMechanismType=NTLM;LastIndexInCCId=-1;OperatorType=Staff;CCLoop=0;pyStatusMsg=;MustReturnContactPoint=TRUE;ProcessType=<your_ProcessType>;SeverityCode=0;ContactPointId=0000771409;AppPage=Group-FW-Foundation-Work-Interaction-InCorr;ReasonText=NO ERROR;Test=;MustReturnServiceRequest=TRUE;DocumentSource=<your_DocumentSource>;CurrentWorkPage=NewClassWorkPage;IsOutBound=error;FileContent=<your_FileContent>


Steps to Reproduce



Initiate an email listener and analyze the Alerts log.


Root Cause



The email content was logged because of PEGA0020 alerts. The alerts occurred because of a Connect SOAP service whose Interaction time exceeded the threshold.


Resolution



Perform the following local-change: Change the logging level of the com.pega.pegarules.session.internal.mgmt.Executable class from ALERT to ERROR.


Published March 9, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us