Support Article

FTSIncrementalIndexer queue increasing and indexes unavailable

SA-32119

Summary



The server hosting indexes ran out of disk space. After that issue was resolved, some search issues were noticed. Re-indexes were attempted, however those indexes would become unavailable when clicking Check on the index or the FTSIncrementalIndexer queue size was large and going down extremely slowly.

Error Messages



java.io.FileNotFoundException: /your_directory/PassivationData/3/H36E610CE06F9EF83190C2D212208B663/EDB%2F%24STANDARD/pyPortal.ser (No space left on device).

Steps to Reproduce



Run out of disk space where indexes are hosted.

Root Cause



A defect or configuration issue in the operating environment:
Running out of disk space likely corrupted the indexes.


Resolution



Perform the following local-change:
  1. Disable FTSIncrementalIndexer agents on all nodes.
  2. Remove the Search Index Host Node ID(s) from the Search Landing Page.
  3. ​Disable all indexing on the Search Landing Page.
  4. Shut down the indexing server(s).
  5. Delete the index files from the server(s) hosting them.
  6. Start the server(s).
  7. Add one node as the Search Index Host Node on the Search Landing Page.
  8. Enable and start Indexing on that one node.
  9. Once the first node is complete, add other Search Index Host Nodes as required.
  10. Start FTSIncrementalIndexer agent on all nodes.

Published January 4, 2017 - Updated January 12, 2017

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