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Support Article

Generic db treatment fails, Outbound Master agent not processing

SA-30824

Summary



In the system test environment the Outbound master has been processing records from staging to the outbound queue correctly until some point. After some time the records remain in staging Pegamkt-Data-Outbound-staging and are not been processed. Template files ( PegaMKT-Data-Outbound-TemplateRun-DB) are not locked. There are records relating to more than one template and none of them are processed.


Error Messages



Not applicable


Steps to Reproduce

  1. From an existing database template perform a save as.
  2. Run a campaign based on the new template.


Root Cause



Given the queries for checking from the staging table had a pzInsKey based condition, if the pzInsKey got changed in few scenarios like save-as, merge the old records get stranded. The fix is just to use the keys (TemplateInsName property) that does not change for the applies to and name of the template.

Resolution



Apply HFix-30668.

Published August 23, 2017 - Updated December 2, 2021

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