Support Article
Global search does not work
SA-86041
Summary
Global search does not work. The Search Index File Size is blank.
Error Messages
Not Applicable
Steps to Reproduce
Search for any work object.
Root Cause
The Search Index files were corrupted. Therefore, the files were not indexed.
Resolution
- Shut down all the nodes.
- Navigate to PegaSearchindex > Node name > Nodes > 0 > indices. The below four folders display.
– data
– help
– rule
– work
- Navigate to data, rule, and work folders.
- Delete the file and folder in these three folders (back up the files and folders before deleting).
- Truncate pr_sys_statusnodes (backup this table before truncating).
- Restart all the nodes. After restarting the indexing node, check the Index node. The Index node must display a positive value.
- Start reindexing for rules, work, and data.
- Search for the work objects when reindexing completes.
Published August 17, 2019 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.