Support Article
Goal and deadline displayed across the screens is inconsistent
SA-74227
Summary
The pySLAGoal and pySLADeadline times do not display consistently.
When creating a child case and opening the assignment, the goal and deadline displayed 6 and 10 days respectively.
When submitting the assignment and navigating to the next screen, the goal and deadline displayed 5 and 9 days though the goal and deadline property values did not change.
Error Messages
Not Applicable
Steps to Reproduce
- Configure a case with an overall Service Level Agreement (SLA).
- Run the case. Verify the goal and deadline displayed on the first assignment.
- Wait for a minute and submit the assignment. Verify the goal and deadline displayed.
Root Cause
This behavior is as per Pega product design.
Resolution
Here's the explanation for the reported behavior:
The change in the goal and deadline days displayed is the expected behavior, since it only displayed the number of days.
For example,
A work object is created with a goal of 4 days. After a minute, the difference is now actually 3 days, 23 hours, 59 minutes. The goal must then be displayed as 3 days.
Hence, the number of days displayed is correct.
Modify the section to display the full date and time or days and hours if required.
Published May 15, 2019 - Updated October 8, 2020
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