Support Article
Hazelcast startup errors after Pega 7 upgrade
SA-27755
Summary
After upgrading from PRPC 6.2 to Pega 7.1.7, startup takes up to an hour and some nodes do not start. Hazelcast errors are observed in the PegaRULES log file.
Error Messages
[8/24/16 17:56:45:258 EDT] 0000002b ConnectionMon W com.hazelcast.nio.ConnectionMonitor [127.0.0.1]:5702 [26a8da66af1c4f42529431b46a9e2d3b] [3.2] Removing
connection to endpoint Address[127.0.0.1]:5703 Cause => java.net.SocketException {Connection refused to address /127.0.0.1:5703}, Error-Count: 6
[8/24/16 17:56:45:213 EDT] 00000025 TcpIpJoiner I com.hazelcast.cluster.TcpIpJoiner [127.0.0.1]:5702 [26a8da66af1c4f42529431b46a9e2d3b] [3.2] Connecting to
possible member: Address[127.0.0.1]:5701
[8/24/16 17:56:45:421 EDT] 00000025 TcpIpJoiner I com.hazelcast.cluster.TcpIpJoiner [127.0.0.1]:5702 [26a8da66af1c4f42529431b46a9e2d3b] [3.2] Connecting to possible member: Address[127.0.0.1]:5709
[8/24/16 17:56:45:462 EDT] 00000025 TcpIpJoiner I com.hazelcast.cluster.TcpIpJoiner [127.0.0.1]:5702 [26a8da66af1c4f42529431b46a9e2d3b] [3.2] Connecting to possible member: Address[127.0.0.1]:5708
Steps to Reproduce
Upgrade to Pega 7.1.7.
Root Cause
Hazelcast is not configured correctly.
Resolution
Perform the following local-change:
- Truncate pr_sys_statusdetails and pr_perf_status tables.
- Restart the nodes one at a time. Allow each node to completely startup before starting the next node. This must be done only once.
Published September 13, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.