Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

HCIF Framework- ICD9 data load- 26 seconds per insert.

SA-5197

Summary



A developer working with the Healthcare Industry Framework (HCIF) v7.6SP2 has encountered a performance problem whereby the developer attempts to load International Classification of Diseases type 9 (ICD9) entries into their HCIF framework database. Specifically, the developer observes load times in excess of 36 hours when attempting to load the ICD9 updates (17,553 records).

Error Messages



No error messages are observed on screen.  Error messages related to the load ARE observed in the PRPC logfile.

2014-12-16 00:01:54,917 [j2ee14_ws,maxpri=10]] [  STANDARD] [   TCW_s2-2:01.01.01] (HG_MilVet_TCW_TCMM_Work.Action) ERROR   - Agent to progress MVP on activity IntakeFlowProgress: Work item at resumeFLOW  status=
2014-12-16 00:01:55,124 [j2ee14_ws,maxpri=10]] [  STANDARD] [   TCW_s2-2:01.01.01] (HG_MilVet_TCW_TCMM_Work.Action) ERROR   - Agent to progress MVP on activity IntakeFlowProgress: Work item  status=

Steps to Reproduce



To reproduce this issue, the customer is executing the following procedure:

a) select the ICD9 option from the customer “To Do” list.
b) At the “ICD9 Codes” browser window, the administrator then selects the EDIT IN EXCEL button.
c) Excel will start, and the workstation waits appr 90 seconds for the 17,553 existing instances to load into Excel
d) Administrator then deletes the contents of the Pega spreadsheet
e) Administrator then copies/pastes the updates from the obtained spreadsheet into the Pega spreadsheet
f) Administrator then commits the changes to the spreadsheet
g) Administrator then waits appr 2 days for the update to complete.

Root Cause



The root cause of this problem is software use/operation error.  Specifically, the administrator is following the wrong procedure to update the ICD9 codes in the HCIF database.


Resolution



The explanation for this behavior is as follows:

The correct procedure to update the codes is found in the HealthCare Industry Framework PDF documentation included in the Framework Distribution kit.  The correct procedure is:

- The business has a subscription with a health care data provider to obtain their ICD9 updates data file.  This data file can be delivered in several formats.  Pega documentation provided in EMAIL details which file formats can be loaded into your HCIF 7.6SP2 framework.

- The Correct Procedure to load this data is to use the Load Sample Codes procedure on page 29 of the HC_Common_Codes_business_Use_Case_Guide_v2.2.pdf.  This document is provided from the PDN to the customer.

This procedure should take only about 10 minutes to load the data file.
 

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us