Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

High CPU utilization reported after upgrade to Pega 7.1.8

SA-12729

Summary



After upgrade from Pega 7.1.7 to Pega 7.1.8, many issues experienced with hang browser, crashed browser or poor response time.
Also experienced high CPU usage on the Application Server. Even when no users were using the system, it still runs at 25% of CPU (total 4 CPU on the system, 100% out of 400%).

When RuleSet import is performed, system
CPU usage is 100% (396% out of 400%).
No user could even get to the login page. Administrator had to kill the JVM process and restart. This occurs frequently with hung user response and out of memory error was reported once.


Error Messages



WSVR0651I: The WorkManager.SRMWorkManager growable thread pool has grown to 26 times its initially-configured maximum of 20.
[7/23/15 9:16:52:192 EDT] 0000009b FreePool E J2CA0045E: Connection not available while invoking method createOrWaitForConnection for resource jdbc/PegaRULES.
[7/23/15 9:17:07:776 EDT] 0000009b DMAdapter I com.ibm.ws.ffdc.impl.DMAdapter getAnalysisEngine FFDC1009I: Analysis Engine using data base: /opt/IBM/WebSphere/AppServer/properties/logbr/ffdc/adv/ffdcdb.xml
[7/23/15 9:17:33:179 EDT] 0000024b CoordinatorCo W HMGR0152W: CPU Starvation detected. Current thread scheduling delay is 10 seconds.
[7/23/15 9:18:40:297 EDT] 0000024b CoordinatorCo W HMGR0152W: CPU Starvation detected. Current thread scheduling delay is 5 seconds.
[7/23/15 9:18:56:241 EDT] 0000024d ApplicationMo W DCSV0004W: DCS Stack DefaultCoreGroup at Member DevCI__1\<your_server>\dev: Did not receive adequate CPU time slice. Last known CPU usage time at 09:18:04:368 EDT. Inactivity duration was 18 seconds.


Steps to Reproduce



Ugrade to Pega 7.1.8 environment from Pega 7.1.7.

Root Cause



DNode Service was contributing to high CPU utilization. 
PRPC system goes into an infinite sleep-check loop when running in Etier (using any EAR deployment). 
A permanent fix for this issue is being evaluated for Pega 7.1.9 or later version. The issue can be completely avoided for sites NOT using DSM functionality just by turning it off with the prconfig setting.

Resolution



Suggested local-change - Disable Pega Decision Strategy Manager DNode functionality by setting the 'prconfig/initservices/dnode/default'  dynamic system setting to "false".  

Published July 31, 2015 - Updated October 8, 2020

Was this useful?

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us