Support Article
I Case not switched on close of a previous I case
SA-55840
Summary
Closing an Interaction case loads the Service case content; however, the Interaction tab focus does not switch.
Error Messages
Not Applicable
Steps to Reproduce
- Create the 1st Interaction case.
- Create a 2nd Interaction case
- Create a 3rd Interaction case
- Create Service cases on the 3rd, 2nd, 1st Interaction cases.
- Switch to the 3rd Interaction case.
- Close the Interaction case on click of the Close (X) icon of the 3rd Interaction case. The last Service case work area is displayed on screen; however, the Interaction tab does not switch.
Root Cause
A defect in Pegasystems’ code or rules
The requests are initiated in the correct order. This is not an issue with the order of request execution. In this case, the first pzUpdateClipboardModels request is triggered with 'ACTIVE' element action value.
On closing the document (tab), the browser cancels all requests that are triggered in that document context. Hence, the server did not execute the pzUpdateClipboardModels activity.
Resolution
Apply HFix-41034.
Published August 24, 2018 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.