Support Article
IE-10: Clicking magnifying glass blocks the browser for 2min
SA-5178
Summary
- Open any section in in Developer Portal in IE10 (Popup blocker deactivated, Compatibility mode activated)
- Open a section, add a pxNumber control, click on magnifying glass
- The browser is now completely blocked for about two minutes. After that, it will open the window correctly and the values can be edited.
The customer upgraded from IE8 to IE10. The issue doesn't occur on a machine with IE8.
Also, we can confirm that the Pegacloud instance we access is trusted in the system policy.
After discussing the issue with our colleagues in UK it turns out they don't have the problem. So we asked them to also run a fiddler trace and compared the both. One of the first differences is that the Locale is set to "DE_CH" for us and "EN_GB" for them. Just in case we tried to change the language of our users to EN and now we don't have the problem anymore.
Steps to Reproduce
- Open any section in in Developer Portal in IE10 (Popup blocker deactivated, Compatibility mode activated)
- Open a control and click on the magnifying glass
- The browser is now completely blocked for about two minutes. After that, it will open the window correctly and the values can be edited.
Root Cause
The root cause of this problem is defect/misconfiguration in the PRPC operating environment. IE10 is not supported for Developer Portals.in this PRPC version.
EN_Gb language option needs to be applied as a workaround.
Resolution
This issue is resolved by making the following change to the PRPC operating environment: Change IE Options language to EN_GB.
Published January 31, 2016 - Updated October 8, 2020
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