Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Iframe does not get expanded automatically

SA-12822

Summary



Developer has created a section and added an Iframe inside a tab layout.They noticed that at runtime, the Iframe contents are not shown on tab.


Steps to Reproduce


 
  1. Add IFrame on a section.
  2. Expand tab with Iframe. Observe that Iframe does not show content.


Root Cause



The root cause of this problem is a defect in customer application code/rules.

Resolution



The explanation for this behavior is as follows:

In the deployment scenario, a  non-pega webpage is embedded inside the iframe which does not seem to load when the iframe is invisible (hidden within a tab).

However the same configuration works for other webpage like pega.com. Removing the webpage from I frame content resolves the issue.
Also, use the "defer load" option on the tab, as the iframe webpage seems to load when the tab body is visible.

 
Suggest Edit

Published August 13, 2015 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us