Support Article
IllegalArgumentException: A blank handle has been specified
SA-76722
Summary
When configuring a case to be processed through an incoming email, the email attachments are not attached prior to the initialization of the first step in the case. As a result, the incoming email is not processed.
Error Messages
java.lang.IllegalArgumentException: A blank handle has been specified.
Steps to Reproduce
- Define a new case type to invoke an activity which performs an Obj-Open-by-Handle using the Primary.pyAttachments(1).pxLinkedRefTo.
- Run the Email wizard.
- Configure the case to be created upon receipt of an email.
- Send an email with an attachment, to the monitored inbox.
Use the Service wizard to create an email service rule. The rule is configured with the standard out-of-the-box pyCreateAndManageWorkFromEmail service activity which invokes the CreateWorkFromMail (standard) activity.

Step 5 in this activity creates the work object and a sub activity. The case is initialized by running the pyStartCase, which attempts to process the first step in the case.
Step 6 adds the attachment from the inbound email to the case. This occurs only after Step 5 has attempted to execute the first step in the case. This generates an error because the first step is an activity which processes attachments.
Root Cause
A defect or configuration issue in the operating environment.
The email was not attached to the case because an assignment in the flow was not added. Additionally, the resume flow step in the pyCreateAndManageWorkFromEmail failed because the lock was not held on the pyWorkPage.
Resolution
Perform either of the following local-changes:
- Define TempCurrentPage of Work- in pages and classes.
- Update the pyCreateAndMangeWorkFromEmail to include an Obj-Refresh-And-Lock step on the pyWorkPage before the ResumeFlow step.
Published April 4, 2019 - Updated December 2, 2021
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