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Support Article

Import Wizard: "No Changes - Instances Already Loaded" message

SA-14379

Summary



The Import Wizard lists rule instances in the import archive that are already present in the target system. These import instances match existing rules in the system. During the import, the wizard skips these instances in the imported archive.
​This is not expected as the system is new and the import archive contains rules instances that have not been imported before.
User is unable find the rules using Designer Studio Search field.

Environment details:
  • Pega 7.1.8
  • JBoss EAP  6.3.3 GA
  • Linux version: 2.6.32-504.12.2.el6.x86_64
  • Microsoft SQL Server 11.00.5058
  • Microsoft JDBC Driver 4.0 for SQL Server 4.0.2206.100


Error Messages



The following instances already exist in the system with the same last modified date.
These instances will be skipped.



Steps to Reproduce

  • Log in to Designer Studio.
  • Launch the Import Wizard (Designer Studio > Application > Distribution > import).
  • Load an import archive and click Next.
  • Select the loaded file and click Next.


Root Cause



The root cause of this problem is defect/misconfiguration in the operating environment. The environment was cloned from an existing one while performing an upgrade. This accidentally led to the copy of development rulesets, not meant to be deployed, to the the target system,
Rules with the same name are included in the import archive, and for this reason, are reported as duplicated.
Search was not working as the configuration was pointing to incorrect old values as a consequence of cloning.
 

Resolution



Perform the following local-changes: 
  1. Restore the Pega database with a backup dating from the migration.
  2. Delete the old rulesets from the database using ad-hoc SQL scripts provided by the Pega Global Customer Support.
  3. The search issue is resolved by the solution provided in support article, SA-14326 (http://pdn.pega.com/node/340991).

Published October 1, 2015 - Updated October 8, 2020

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