Support Article
Incomplete Index issue in production environment
SA-46118
Summary
Index in Production is incomplete and last item in the queue is 8 months old.
Error Messages
Work Index File Is Incomplete
Steps to Reproduce
Not Applicable
Root Cause
In System Management Application (SMA) application, analysis of the indexing queue show that there are few old indexing items (around 10) with status "now-processing" but which are obviously not being processed as the agent wakes up and sleep without any change in their status.
Resolution
Perform the following local-change:
- Go to SMA >Queue Management >System Queue Management.
- Select checkbox for queue with status "Immediate" and click "Details". For each old stuck indexing queue item (class SYSTEM-QUEUE-FTSINCREMENTALINDEXER) , click "Requeue".
- Check then if the item is indeed processed, that is, disappear of the list after a minute.
- Try to remove all old instance of class SYSTEM-QUEUE-FTSINCREMENTALINDEXER.
Published March 19, 2018 - Updated October 8, 2020
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