Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Incorrect applies to class after upgrade to Pega 7.1.8

SA-13018

Summary



In PRPC 6.3 SP1 a Flow Action rule of Work-xxxx class referred to a section of Data-xxxx class through the "Using Page" option. After an upgrade to Pega 7.1.8, in the Flow Action rule form, the Page "Applies to" class defaults to Primary Page class, Work-xxxx. It does not take into the account the Data-xxxx class defined in the Pages and Classes Tab.

Error Messages



Not Applicable.


Steps to Reproduce

  1. In an application create a Flow Action rule of in Work-xxxx class and refer a section of Data-xxxx class through "Using Page" option.
  2. Migrate the application in Pega 7.1.8.
  3. The issue can be verified by opening the flow action rule in Pega 7.1.8 or by running the revalidate and save. It shows a validation error.


Root Cause



The root cause of this problem is a upgrade issue.

Resolution



This issue is resolved through the following local-change:
  1. Run the revalidate and save for flow action. It must show validation error for such type of flow actions.
  2. Update all the flow actions manually and save them.

Published August 12, 2015 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us