Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Insufficient privilege error when Importing application

SA-2986

Summary



We have two Pega servers running on Oracle. When exporting an application from one and importing to the other, we encounter an insufficient privileges error.

Error Messages



Database-General Problem Executing SQL to update database schema

ORA-01031: Insufficient Privileges

Steps to Reproduce



1. On first server created a new application.
2. Create Rule-Admin-Product using packager.
3. Create a JAR file using export operation.
4. On another server attempt import. Observe error.


Root Cause



The root cause of this problem is defect/misconfiguration in the PRPC operating environment. The PegaRULES database user was not provisioned with all of the necessary privileges.



Resolution



This issue is resolved through the following local change: Provision the database user with all appropriate database privileges as outlined by the Deployment Guide.

https://pdn.pega.com/resources/deployment-guides
Suggest Edit

Published January 31, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us