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Support Article

Intents not displayed based on Task DIsplay Order, CSHC 7.1.3

SA-18353

Summary



In Pega Customer Service 7.1.3, intents are not displayed in the task display order, here order means the task instances created.

Error Messages



No error message. Order of the intents is incorrect.

Steps to Reproduce



Below are the steps to be followed to reproduce the issue:

1. Go to Designer Studio>CPM>Interactions>Interaction Driver.
2. Go to the third tab, that is Interaction Task.
3. Click on Run.
4. Now list of tasks can be seen.
5. Click on Address Change
6. Change the number in Task Display Order.
7. Click on CloseAccount and change the Task Display Order.
8. In the same way change the Task Display Order for StatementCopy.
9. Launch the Interaction Portal, using the path, New>Phone Call>Select a contact, and On Click of Add Task button,output can be checked.


Root Cause



The intents are not sorted respecting the task order property in Task List Menu while preparing D_Interaction_Driver page.

Resolution



Apply HFix-25479.
 
 
Suggest Edit

Published January 31, 2016 - Updated December 2, 2021

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