Support Article
Interaction history is being recorded incorrectly
SA-31675
Summary
Interaction History is getting recorded incorrectly for the marketing campaigns. There are duplicate entries in the interaction history for each interaction.
Error Messages
Not applicable
Steps to Reproduce
1. Create a marketing_campaign.
2. Run the marketing campaign.
3. Check the interaction history, it should have same number of rows as the offers made.
Root Cause
Users were expecting the number of offers sent during the marketing campaign should match with the records in the interaction history table for any particular campaign.
Resolution
The additional records captured in the Interaction table is due to the enabling of impression capture in the Email treatment of the Campaign.
Published August 23, 2017 - Updated December 2, 2021
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