Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Invalid triggers in database after upgrade

SA-22048

Summary



The following triggers are invalid after upgrading an environment:

TRPCA_RULE_ASSOC_CTIP
TRPR4_RULE_PROP
TRPR4_RDP
TRPR4_REQ
TRPR4_USE
TRPR4_FIELDVALUE
TRPCA_RULE_ASSOC_KC
TRPR4_RULE_FLOW
TRPR4_RULE_SHORTCUT
TRPR4_RULE_AUTOTEST
TRPR4_RULE_MESSAGE
TRPCA_RULE_CAMPAIGN
TRPCA_RULE_TASK
TRPCA_RULE_ASSOC_DIALOG
TRPCA_RULE_KC
TRPCA_RULE_DIALOG


User requires to know the necessity of these, if so, why are they invalid and how should that be addressed?


Error Messages



Not applicable


Steps to Reproduce



Upgrade environment by using a third party tool to move the data.


Root Cause



A defect or configuration issue in the operating environment. Because the data was moved using a third party tool, these triggers are referencing schemas that do not exist in current environment, specifically the data schema which has a different name than it did in a earlier environment.

Resolution



Make the following change to the operating environment: 

​To correct this issue, the DBA must update the triggers so that they are pointing to the correct data schema for the current environment.

 

Published April 13, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us