Support Article
Issue with batch job which creates multiple users
SA-4680
Summary
There is an issue being reported in production with a batch job for creating multiple user accounts at the same time. The job is giving error with message “Role not found in database for name: callcenteragent”. This behavior has been observed after the cache value was changed from 10000 to 20000
Error Messages
Role not found in database for name: callcenteragent
Steps to Reproduce
There is an issue being reported in production with a batch job for creating multiple Trio user accounts at the same time. The job is erroring out with message “Role not found in database for name: callcenteragent”. This behaviour has been observed after the cache value was changed from 10000 to 20000
Root Cause
The root cause of this problem is a defect in production environment setting wherein cache size was not updated in a particular JVM where the batch job was run. Cache size for DefaultCache region had to be updated in all the JVMs.
Resolution
The root cause of this problem is defect/misconfiguration in the custom environment. DefaultCache region value was updated(from 10000 to 20000) in the JVM to resolve this issue.
Published January 31, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.