Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Issue with Custom HTML in Modal dialog - Post Migration

SA-8557

Summary



User upgraded from PRPC 5.5 to Pega 7.1.7. After upgrade, on submitting a Modal dialog (Local action from a flow action screen), message is not displayed in Modal dialog , only the action buttons are displayed.

Error Messages



Not Applicable.

Steps to Reproduce



1. Create a enquiry case.
2. Fill up required details and submit.
3. Reassign the case (flow action).
4. Search the operator to be assigned.
5. Search options appears in a modal dialog.
6. Select the operator from the results and submit(Ok- button).
7. If unprevilaged user is selected and on submit an error stating "unprevilaged user is selected" should be displayed.
but the error message is not visible on submitting


Root Cause



 The rootcause of the issue was using on ModalHTML in user activity which is causing two modal dialogues to open.

Resolution



Use ActivityStepHTML insted of ModalHTML in the activity, which resolves the issue.
Suggest Edit

Published June 12, 2015 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us