Support Article
Issue with filter search results
SA-19599
Summary
When developer makes use of the filter functionality on the grid, an option of Search along with a text box is displayed to enter the value. When any value is entered in the text box and the search button (binocular) is clicked, nothing happens.
Error Messages
No error messages but it does not show any output.
Steps to Reproduce
This is out of box functionality and can be checked with any grid. In Pega Product Composer for Healthcare application, click on Plan from the left panel, a list of plan with details would come on the right panel. Most of the fields would have filter option.
- Click on Filter on the grid.
- Popup would appear with the text box and search button (binocular)
- Enter value in the text box and click on search button.
- Nothing happens. It does not work. This was reported as an issue.
Root Cause
This is an expected behaviour of product.
Resolution
The reported issue is an expected product behavior.
Refer supporting PDN article containing mechanis of filtering - https://pdn.pega.com/presenting-grid-results,
Tags:
Published February 15, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.