Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Issue when multiple survey questions use the same property

SA-2099

Summary



After upgrading to Pega 7, display issues occur when multiple questions use the same property.  The question is configured to display the answer using a radio button.  If the user clears the radio button, they are unable to select the radio button again.  The selection is not retained.

Error Messages



No error messages

Steps to Reproduce

  1. Run the process to start the survey.
  2. Select Yes for question 1, which then displays question 3.
  3. Select No for question 3, which then displays question 4 with the radio button selected.
  4. Clear the radio button by clicking the Clear Selection button.
  5. Change the prior question answer to Yes and then back to No. The radio button for question 4 is not automatically selected.
  6. Click on the radio button to select but the selection is not retained.

Root Cause



The root cause of this issue is multiple questions are referencing the same property and the Refresh option was selected for those questions.  When the user tried to select the radio button it was refreshing and resetting the value based on the previous question associated with that property.

Resolution



Uncheck the Refresh option for the question.   
 
Suggest Edit

Published January 31, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us