Support Article
Issues with refreshing the browser
Summary
Application case type is accessible through the guest login. However, error message displays on the form on clicking the browser refresh.
Error Messages
This action is not allowed as it is outside the current transaction.
Steps to Reproduce
1. Log in as the guest user
2. Move to the second screen
3. Perform a browser refresh
Root Cause
The transaction ID is not nullified.
Resolution
Perform the following local-change:
Add the below script to the UserWorkForm:
<script>
function TransactionIDIssue(){
var newurl = SafeURL_createFromURL(pega.u.d.url);
newurl.put('pzFromFrame','');
pega.u.d.url = newurl.toURL();
var url = document.forms[0].action;
var formURL = SafeURL_createFromURL(url);
formURL.put('pzFromFrame','');
document.forms[0].action= formURL.toURL();
}
TransactionIDIssue();
</script>
Published October 19, 2019 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.