Support Article
Issues on UI Rules Check Out/In and Delete
Summary
UI rules are not being checked out/in and delete in Developer login. For example:
1. Paragraph Rule is not able to be checked out. Nothing happened when clicking "Check out" button. Delete Paragraph Rule gives blank mode window.
2. Checking out Section rules gives "Ajax request failed".
3. In fiddler "The specified URL cannot be found. " is being sent by the server.
All other functionalities works like - SaveAs/Refresh/Other.
Issue is replicable in QA and Production environment. In Development environment, issue is not replicable.
Error Messages
Fiddler 404 error; Ajax request failed;
Steps to Reproduce
1. Open a Paragraph rule and click "Check out" button.
2. Nothing happen - Fiddler shows 404 error.
3. Click "Delete" button, shows a mode window with only a "Submit" button.
4. Section Rule is able to check out but gives "Ajax request failed". Fiddler shows 404 error; Delete rule is ok.
Root Cause
The request header's Referer formed does not match for both replicable and non-replicable cases. prevContentID and prevRecordkey parameters are missing.
Replicable Case - Referer header:
https://................:8443/prweb/PRServlet/Wd2EfcrGVDleeUSdHWQhuaF0riLOmqTNXfHCrnEZQuo%5B*/!TABTHREAD0?pyActivity=%40baseclass.doUIAction&action=openRuleSpecific&openHandle=RULE-HTML-PARAGRAPH%20DATA-PORTAL%20MACSHOMEPAGEEXTERNAL%20%2320151222T203332.459%20GMT&Format=harness&contentID=ea87c9d1-af01-af78-5ca1-6e014e32a05d&dynamicContainerID=de12ecd7-b2b3-4849-bff1-ee2797014513&tabIndex=3&prevContentID=0944c566-575b-7829-03ec-868e5ce75d5b&prevRecordkey=RULE-RULESET-NAME%20NJJMUNBUSINESSADMIN&portalThreadName=STANDARD&portalName=Developer&pzHarnessID=HID8EA862E93F42C7C3CC906946949CEC8B
Non-replicable - Referer header:
https://.............../prweb/PRServlet/Wd2EfcrGVDleeUSdHWQhuaF0riLOmqTNXfHCrnEZQuo%5B*/!TABTHREAD0?pyActivity=%40baseclass.doUIAction&action=openRuleSpecific&openHandle=RULE-HTML-PARAGRAPH%20DATA-PORTAL%20MACSHOMEPAGEEXTERNAL%20%2320151222T203332.459%20GMT&Format=harness&contentID=778f77df-232a-dbee-4b03-c8732d1abfd1&dynamicContainerID=de12ecd7-b2b3-4849-bff1-ee2797014513&tabIndex=2&portalThreadName=STANDARD&portalName=Developer&pzHarnessID=HID8CB9002310740F3EFF7167680BE1CC78
Load Balancer was being used in user environment and on hitting the URL directly, the issue was not reproducible.
Resolution
It was environmental issue; network configuration was reviewed.
Published September 21, 2016 - Updated October 8, 2020
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