Support Article
Issues while adding attachments to the workrequests.
SA-26304
Summary
If work requests are open in different tabs, and if a user tries to add an attached to each of the work requests, the tab is refreshed but the attachment is not added.
Error Messages
Not applicable
Steps to Reproduce
1) Open more than one work requests in different tabs.
2) Try to add file attachments to each work request.
3) Observe the files will not get attached to the Work ID.
Root Cause
An issue in the custom application code or rules
In the custom activity ABC there is a when condition "param.pzTransactionId==pxRequestor.pxClientExchange" which was failing due to which activity to add attachments is not getting called.
Resolution
Removing the When condition resolves the issue.
Published August 10, 2016 - Updated October 8, 2020
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