Support Article
Issuess with the load balancing configuration
SA-18850
Summary
Page load issues while logging in Designer Studio after that Load Balancing of Pega nodes has been put in place in Pega 7.1.8.
Login occurs correctly but the Guardrail Warnings widget in the Landing Page hangs with a "Loading" message and Recent Items list couldn’t be loaded as shown in the screenshot below
The issue occurs only accessing the application through HTTPS while accessing with HTTP does not cause the issue.
User Environment Details:
- Citrix NetScaler MPX 8200
- WebSphere 8.5.5.4
- Pega 7.1.8
Error Messages
No Error message found in the logs.
The screen does not complete to load.
Steps to Reproduce
Log into Designer Studio.
Root Cause
A third-party product issue.
Fiddler traces of the reported scenario highlighted that some POST Requests in the request body are served with a "HTTP/1.0 302 Object Moved" response code.
The HTTP 302 responses are happening when POST Requests, submitted with the HTTPS protocol, contain XML or JSON payloads in the request body as shown below:
Replaying the request removing the the XML payload from the request body cause the requests to be served correctly.
Server-side traces show that the failing https requests are dropped by the network appliance and don't reach the Pega application.
The network appliance is configured to leverage the SSL Offload feature to expose HTTP back-end services over HTTPS.
The same requests are served correctly using HTTP hence the issue is caused by a wrong SSL configuration.
Resolution
Make the following change to the operating environment:
Adjust the configuration of the network appliance in the following way:
Old setup:
Client > https > Content Switching (CS Policy) > Load Balancing VIP > Backend Services
New setup:
Client > https > Load Balancing VIP > Backend Services
Published January 26, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.