Support Article
java.lang.ArrayIndexOutOfBoundException errors appearing in log
SA-41275
Summary
Log file is showing out of bounds errors for the ChannelServices-Event-.SendToDesktop activity.
Error Messages
java.lang.ArrayIndexOutOfBoundException:1
Steps to Reproduce
This occurs for some operators when attempting to answer a call.
Root Cause
Some operator records do not have a workstation ID and the ChannelServices-Event-.SendToDesktop activity requires that value to be supplied in the _ChannelParam parameter.
Here is the indicator of exactly what line is failing due to the invalid CTIEvent.pyWorkStationId :
. . .
// Due to compatilbity concerns, classic CTILink has a shortened HTTP presence id string
// with just the Requestor ID
String reqID="";
if (presenceAgent.contains("Channel"))
reqID = presenceAgent.split("ChannelParam=")[1]; < = = = = = =
else
reqID = presenceAgent;
. . .
Resolution
Supply a ChannelParam parameter to the ChannelServices-Event-.SendToDesktop activity or avoid calling the activity if none is available.
Published August 26, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.