Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

javax.mail.AuthenticationFailed error for shared mailbox, IMAPS

SA-38437

Summary



Developers are getting an authentication error when trying to connect to a shared mailbox using IMAPS.

The connection works fine when connected through Outlook.


Error Messages



2017-05-18 16:06:14,533 [fault (self-tuning)'] [TABTHREAD1] [ ] [ Test3:01.01.01] (ivity.Data_EmailAccount.Action) ERROR your_host.com your_user - Data-EmailAccount.your_email_account: The server indicated that the authentication credentials for this Email Account are incorrect.
javax.mail.AuthenticationFailedException: AUTHENTICATE failed.
at com.sun.mail.imap.IMAPStore.protocolConnect(IMAPStore.java:717)


Steps to Reproduce



Configure an email listener to access a shared mailbox and use IMAPS as the protocol.


Root Cause



When accessing a shared mailbox, the system sometimes requires that plain authentication be disabled, depending on the email server in use.

Resolution



Perform the following local-change:

On the Email Account rule form, under the Receiver section, add the following advanced property and set its value to true:

mail.imap.auth.plain.disable
Suggest Edit

Published February 8, 2018 - Updated October 8, 2020

Did you find this content helpful? Yes No

50% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us