Support Article
jmxclient.css and global.js files not found when running SMA
Summary
Errors are exhibited in the log file when running prsysmgmt and while navigating to 'system queue management' page or System Management Application (SMA).
Error Messages
[12/10/15 12:09:27:457 EST] 0000010d filter E com.ibm.ws.webcontainer.filter.FilterInstanceWrapper doFilter SRVE8109W: Uncaught exception thrown by filter struts2: java.io.FileNotFoundException: SRVE0190E: File not found: /jsp/services2/js/global.js
[12/10/15 12:09:27:457 EST] 00000110 filter E com.ibm.ws.webcontainer.filter.FilterInstanceWrapper doFilter SRVE8109W: Uncaught exception thrown by filter struts2: java.io.FileNotFoundException: SRVE0190E: File not found: /jsp/services2/css/jmxclient.css
Steps to Reproduce
Navigate to SMA or System Queue Management.
Root Cause
A defect in GenericHTMLMBeanOpResult.jsp, including two paths for global.js and jmxclient.css something like below:
< script src="../../js/global.js"></script>
< script src="./js/global.js"></script>
The second one is the cause of the issue. This can be modified to a single statement
< script src="<%=request.getContextPath()%>/js/global.js"></script>
Resolution
Perform the following local-change:
- Modify services2/GenericHTMLMBeanOpResult.jsp in prsysmgmt.war
1) Find the following lines:
< script src="../../js/global.js"></script>
< script src="./js/global.js"></script>
2) Remove one of the lines.
3) Replace the other line with:
< script src="<%=request.getContextPath()%>/js/global.js"></script>
- Repeat steps 1 to 3 for jmxclient.css (instead of global.js)
- Redeploy the .war on the server.
Published January 30, 2016 - Updated October 8, 2020
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