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Support Article

Lead refresh doesn’t work

SA-59700

Summary



In the ‘Sales Automation for Sales Ops’ portal, Leads view does not refresh for Individual or Business filter. This occurs after creating a new Lead.


Error Messages



Not Applicable


Steps to Reproduce

  1. Create a new Individual lead.
  2. Navigate to the leads list.
  3. Switch the filter between All and Individual. Ensure the lead is presented.
  4. Return to All without filters.
  5. Open the lead
  6. Close the Lead by specifying any reason.
  7. Refresh the Leads list. Ensure it is removed from the All view.
  8. Navigate to the Individual view. Refresh it.
     

Root Cause



A defect in Pegasystems’ code or rules.

The issue does not occur with ‘SA for Sales Rep’ portal on comparing the SFAPortalMenuItems Navigation rule with both the PegaCRM-Portal-SFA-SalesOps and PegaCRM-Portal-SFA-SalesRep classes. The actions differ for the Leads label.



Resolution



Perform the following local-change:
  1. Save the SFAPortalMenuItems Navigation rule present in the PegaCRM-Portal-SFA-SalesOps class to the user application.
  2. Update the Leads Menu action to use the RemovecrmLeadsListDPage data transform instead.
     

 

Published October 27, 2018 - Updated December 2, 2021

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