Support Article
Lead refresh doesn’t work
SA-59700
Summary
In the ‘Sales Automation for Sales Ops’ portal, Leads view does not refresh for Individual or Business filter. This occurs after creating a new Lead.
Error Messages
Not Applicable
Steps to Reproduce
- Create a new Individual lead.
- Navigate to the leads list.
- Switch the filter between All and Individual. Ensure the lead is presented.
- Return to All without filters.
- Open the lead
- Close the Lead by specifying any reason.
- Refresh the Leads list. Ensure it is removed from the All view.
- Navigate to the Individual view. Refresh it.
Root Cause
A defect in Pegasystems’ code or rules.
The issue does not occur with ‘SA for Sales Rep’ portal on comparing the SFAPortalMenuItems Navigation rule with both the PegaCRM-Portal-SFA-SalesOps and PegaCRM-Portal-SFA-SalesRep classes. The actions differ for the Leads label.
Resolution
Perform the following local-change:
- Save the SFAPortalMenuItems Navigation rule present in the PegaCRM-Portal-SFA-SalesOps class to the user application.
- Update the Leads Menu action to use the RemovecrmLeadsListDPage data transform instead.
Published October 27, 2018 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.