Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Left Navigation Panel in classic portal not working

SA-9787

Summary



User is using classic portal ( work manager ) and trying to check it behavior at their end.
Because their end users are on IE8 but they are usign IE10, they are doing this testing by changing the browser mode to IE8 and document mode to IE8 standards.

At runtime, after launching the work manager portal , whenever they are clicking any tab on left navigation panel, the rest of the tabs are getting vanished and the entire screen is getting hung.



Steps to Reproduce



1) Login to PRPC 7
1) Add WorkUser/WorkManager portal to the access group
2) Launch the portal

Root Cause



The root cause of this problem is a defect in Pegasystems’ code/rules.
Fixed portals are compatible only in IE5 Quirks document mode, Hence, these portals not work as expected in Standards document mode.
Fixed portals are deprecated in pega 7, Refer PDN for the same https://pdn.pega.com/release-notes?version=8431​

Resolution



The explanation for this behavior is as follows:
It is expected to upgrade the fixed portals to composite portals. It will be fixed if we add meta tag for IE5 quirks in framesetusers rule, However, it is a deprecated rule. Hence, Rule can not be modified.

 
Suggest Edit

Published June 12, 2015 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us