Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Listener not starting up with secured IMAP on port 993



There is a mailbox upgrade happening within User whereby all mailboxes are upgraded to Outlook 2010. Changes were done to Pega email accounts/server running on Pega 7 and PRPC 6 versions. 

The Pega7 listeners started up successfully. However, PRPC 6 listeners with the same values given didn't start up.

Error Messages

Caused by: javax.mail.MessagingException: Could not connect to SMTP host: imap-uat, port: 465; 
nested exception is: Connection refused 
at com.sun.mail.smtp.SMTPTransport.openServer( 

Steps to Reproduce

1. Open any Email Server in PRPC 6.2 
2. Update the config to use IMAPS (i.e with Use SSL checked) 
3. Update port number to 993. 

Root Cause

The root cause of this problem is the issue with version 6.2 SP1 where PRPC EmailListener will ignore the port for outbound mail and always connect using SMTP or Secure SMTP.  As the user have disabled the SMTP on their email server, listener fails to start up.


This issue is resolved by adding the below DSS setting.
Owing ruleset: "Pega-IntSvcs"
Purpose/description : email/blockResponse 
Value = true

This setting will enable the EmailListener to block the test connection to the response server via SMTP.

Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us